Sunday, August 5, 2007

MSI P6N SLI Platinum Motherboard -- Installation Ordeal

I bought an MSI (Micro-Star International) P6N SLI Platinum LGA 775 NVIDIA nForce 650i SLI ATX. The process of installing it was an incredible ordeal. I do not know how much of that ordeal was due solely to the motherboard. I can say that I had installed a Gigabyte GA-8IG1000MK motherboard just a year earlier, with largely the same software (e.g., Microsoft Windows XP and Office 2003, Adobe Acrobat, Firefox), and had not had remotely this level of difficulty. My installation hassles in this case were the second-worst in my 20+ years of assembling PCs -- second only to the experience I had in 1996, when I spent literally months receiving and returning defective computer merchandise. After 1996, I had learned the lesson of being sure to buy quality components. I also learned another lesson, which was to have a second computer handy, so that you could go online to research things. I did not re-make either of those mistakes this time around. I did forget a third lesson from 1996, however, which was to have a second, hardware-compatible computer onsite, to permit swapping of components for testing purposes. With only one computer, it was a guesswork situation. Absent good diagnostic programs, which were not always available for all components, it was not always clear which component was at fault, or if it was even a hardware problem at all. In this case, I did return the motherboard for a replacement. That, however, did not resolve matters. Over the course of six weeks, I had major, extremely time-consuming and frustrating problems with system crashes and a baffling inability of the system to recognize my Canon scanner. Again, neither of these had been problems on the Gigabyte system. At the time of starting this post, I had several problems in Device Manager (i.e., Start > Settings > Control Panel > System > Hardware > Device Manager). Each of those problems was marked with a yellow circle containing an exclamation mark (referred to here as a "yellow exclamation"). These problems were of two kinds. The more hopeful kind occurred where Device Manager was actually able to identify the device in question. Thus, for instance, under Imaging Devices, Device Manager showed a yellow exclamation next to what it called "MF5730," which I knew was short for my Canon MF5730 multifunction machine. Not to make too much of the optimism here, I also had a yellow exclamation on something called "Unknown device" under the "Sound, video and game controllers" heading. The less hopeful kind of mark occurred where Device Manager seemed to have little to no idea what kind of device was having a problem; it just knew that there was something not working right. In these cases, it showed the yellow exclamation on top of a yellow question mark (which combination is referred to, here, as simply a "yellow question"). At this point I had two yellow questions, both appearing under the heading "Other devices." One was called "PCI device," and the other was called "Unknown device." (I will refer to both yellow exclamations and yellow questions as, collectively, "yellow problems.") In a bid to remove these yellow problems, I went to each one, there in Device Manager, right-clicked on it to bring up the context menu, selected "Update driver," and allowed the Hardware Update Wizard to search for a solution (having already installed all of the relevant software available to me on installation CDs and from manufacturers' websites). To my delight, this seemed to resolve the Canon MF5730 problem. To check, I went into Acrobat and tried scanning a page and then printing it. It worked. The solution to this problem appeared, then, to be to reinstall Windows and then keep installing updates for WinXP and for Acrobat until, now, the problem finally went away. I was not so fortunate with the other yellow exclamation. The driver update procedure just described succeeded in converting it from "Unknown device" to "nVidia WDM Video Capture (universal)"; but I still wound up with a hardware error message and an indication that the device "cannot start." I tried again with the same process, and this time got an indication that "The wizard could not find a better match for your hardware than the software you currently have installed." But now that the item was identified, I thought it might be worthwhile to try again with an installation of the WDM driver download from the NVIDIA website. So I ran it, electing (when it asked me) to overwrite all already existing files. But what came up was a question of whether I wanted to uninstall it. I thought, sure, OK, why not? I set a System Restore point, uninstalled, and rebooted. Interestingly enough, this left me with only one yellow question, "PCI Device" under the "Other devices" heading. For that yellow question problem, I used the same procedure as above, but this resulted in a message, "Cannot Install this Hardware. The hardware was not installed because the wizard cannot find the necessary software." So now I tried a different approach. Brahma at SharkyForums pointed me toward a program called Unknown Devices.exe at Oddly, when I tried bringing that Unknown Devices program over from the laptop, where I had downloaded it (and where I was doing this logging and researching), to the desktop, where I intended to install it, I found that the newly installed desktop system did not work with the flash drive I was using for the file transfer. Device Manager recognized it as a Data Traveler drive, but there was a yellow exclamation next to it. When I updated its driver, it appeared as a USB Mass Storage device, but I could not see it in Windows Explorer. On reboot, that problem disappeared. I still had just that one yellow question. (I was also getting the Found New Hardware Wizard at eacch reboot; and when I would let it run, it would give me the same "Cannot Install this Hardware" message as above.) I ran the Unknown Devices program and got this report for the yellow exclamation item: PCI Device Unknown Device and Vendor, PNPID: VEN_10DE&DEV_026C&SUBSYS_73501462&REV_A2 Full Details PNPID VEN_10DE&DEV_026C&SUBSYS_73501462&REV_A2 Windows Detected Device PCI Device That wasn't too informative -- it really didn't give me anything more than I had found in the Properties > Details tab when I right-clicked on the unknown item -- so I tried again. Boheemee at SharkyForum recommended Craig's PCI32. The results of this little program (read the ReadMe file) were more informative but complex. I couldn't really tell which of the many listed items was the one I was having problems with, so I searched in the resulting report for a string from the data just quoted. That is, I searched for 73501462. This string appeared in eleven of the entries shown in the report. I couldn't really understand the output, except that I noticed that, in each case, the Vendor was Nvidia Corp and the Subsystem Vendor was MSI. So at least I had narrowed the problem down to a motherboard driver, which I probably could have guessed at in the first place. The specific functions seemed to vary from one entry to the next: one referred to "HyperTransport Capability," while another referred to "PCI Class Bridge." It seemed I needed one or more motherboard drivers that I wasn't getting from either the installation CD or the download (despite numerous attempts to install drivers from both sources) -- and that MSI's Live Update website wasn't identifying either. According to that website, I could do a minor BIOS update, or I could install some utilities, but there were no newer drivers that might have solved the problem. I installed one of the utilities, which looked like it might be useful, and I did the BIOS flash and then rebooted. On reboot, I got a dialog bubble, down by the system tray, stating "Found New Hardware. PCI Device." It endured, as before, for as long as the Found New Hardware Wizard was once again waiting for permission to run. In short, the BIOS update did not change the situation in Device Manager, nor did letting the hardware wizard run. A number of postings mentioned that the yellow question next to a "PCI Device" entry in Device Manager seemed to be associated with a loss of sound capability. Sure enough, when I tried to play a WAV file using Windows Media Player, I got a message, "Windows Media Player cannot play the file because there is a problem with your sound device." I got a similar message when I tried to play the WAV file with IrfanView. So we seemed to have determined that I was missing an MSI and/or NVIDIA sound driver. I went to Control Panel and, by accidentally clicking on a button I didn't intend to click, managed to uninstall the NVIDIA stereo driver. As I reviewed my collection of drivers, I noticed that I didn't actually have an audio driver from NVIDIA. What I had was a stereo driver that I had downloaded from the EVGA website. That seemed odd, because my EVGA card didn't have audio outputs. With the EVGA or NVIDIA driver gone, I tried to update the driver for the unknown PCI device in Device Manager. That still didn't work. I went back to the MSI download site, to see if they would now detect that I was missing a driver. They didn't. That made me wonder whether I had possibly done the right thing in uninstalling the EVGA driver. But Device Manager hadn't changed, and I was still getting an error message when I tried to play a WAV file. In a post from 2004, Alore Duncan posted information regarding the Intel Chipset Software Installation Utility -- which, s/he said, was an essential first install (after installing the operating system and its updates), for purposes of helping hardware and software connect. But, of course, I was running an NVIDIA, not Intel, chipset, and therefore could not use this advice. After browsing some other links without satisfaction, I went to the NVIDIA website and tried downloading what seemed to be the right driver, the nForce 650i SLI driver (filename 8.43_nforce_650i_winxp32_english.exe), and installed it. Frustratingly, it did not seem to be installing anything related to audio: the files that it said it was installing had to do with the NVIDIA SMBus Driver (where SM turned out to mean "system bus"), the NVIDIA Ethernet Driver, and the NVIDIA MediaShield. It said it found previously installed Ethernet drivers and would need to uninstall them and reboot. I set a System Restore point and said sure, go ahead. This uninstall and reinstall did not seem to change anything, however. I went to the NVIDIA forums and, after browsing around, posted the problem. Then I rebooted to make a drive image backup of the system thus far -- when, to my amazement, I found that I could not use the keyboard! It seemed that the BIOS update I had just installed must have screwed things up, so that I could use the keyboard only inside Windows. If I tried hitting the Del key to go into BIOS setup, or if I booted from some other CD and tried using the keyboard to enter commands into whatever came up there, there was no response. I contacted NVIDIA tech support by e-mail:

1. Your 1.40 BIOS update appears to have screwed up my keyboard. There is no response to DEL -- can't get into BIOS. Also can't type commands into another program that I boot from CD. Keyboard works OK inside XP. 2. Suggestion for design of this form: don't require people to post all this information. Just tell them that you will have to point them back to this form if the info they do supply is inadequate to answer the question, and let them take their chances. None of these variables have changed, in my case, since an hour ago; they are not responsible for the problem. I am just trying to let you know of an issue that will not affect me personally if I return this board to the seller.
To my surprise, I got a response back on the same day -- on a Sunday. The reply told me that I should not have upgraded the BIOS if I was not having a problem (though, as the foregoing paragraphs show, I actually did think I was having a problem). His advice:
it is strongly [recommended] not to flahs or update to any bios version when current version has no problem with the setup which MSI has warning in the Live Update utility. After the bios update for the mb, the following steps must be done: Power off the system and clearing the cmos setting on JBAT1 jumper/button or cmos battery removed for at least 1 minute. Set all JBAT1 jumper and cmos battery into the system board to default position. Power on the system and go into the cmos setup and reload the cmos default settings. Re-configure the bios setting to match with your system configurations. If you can get into windows with KB support then flash back to the previous bios version if possible. If it is an USB KB, try with enable/disable the USB Legacy Support in the bios setup as well if you can get into the cmos setup by using a PS2 KB or after the cmos clear.
I did as he said, and things were fine. I didn't even need to reload BIOS version 1.30. So I was back to the "Cannot Install this Hardware" problem. I called MSI tech support at noon on a Tuesday, and was pleased to reach a technician within just a minute or two. He had me reboot, hit Del, go into the BIOS setup, and disable the HD Audio Controller. Upon reboot, I saw that the PCI Device yellow question was gone. I'm not sure why he did that. Maybe it was a test. He had me go back into BIOS setup and re-enable the HD Audio Controller. He concluded that what I might want to try was to load my drivers in this order: 1. nForce 650i SLI system driver 2. SATA RAID driver 3. Realtek hi-definition audio driver In my case, I interpreted this as meaning I should install the drivers in the following order, using the drivers that I had downloaded from the NVIDIA website: 8.43_nforce_650i_winxp32_english.exe 162.18_forceware_winxp_32bit_english_whql.exe 4.13_forceware_wdm.exe For the other problem, the yellow exclamation next to nVidia WDM Video Capture (universal) under Sound, video and game controllers in Device Manager, he recommended I contact EVGA, manufacturer of my video card. He wondered if maybe the onboard audio on my motherboard was bad, but I had already had the audio working in a previous WinXP installation, a week or two earlier. I wasn't too keen to reinstall everything, which was what he recommended: do a fresh Windows install and install the drivers in the right order, which was hopefully the order just described. Reinstalling the whole system, with updates and all, was a very time-consuming process, sure to take another couple of days, which I didn't really have to spare at that time. Then again, when he was guiding me through those steps with the BIOS, I asked him why my system was so slow to reboot, and he ventured the opinion that this sometimes happened when people uninstalled things. So I was thinking that maybe I should reinstall to try to get past the slow boot problem. I thought about uninstalling all of my NVIDIA drivers and then using DH Driver Cleaner Professional and Advanced WindowsCare Professional (discussed in another post), in that order, and then reinstalling the drivers in the specified order, to see if that would solve the problem. I also thought about giving up on Windows and trying Ubuntu again. I decided to do the least radical thing first, so I uninstalled the yellow exclamation-marked items in Device Manager, uninstalled all NVIDIA drivers, and also the Realtek Audio drivers, rebooted, cancelled out of the inevitable Hardware Wizards that came up, and then used the two cleaning programs just mentioned. AWC, I should mention, found 387 registry problems and 81MB of junk files to remove. Plan A was to reinstall the drivers in the stated order. But then I thought maybe I should use the installation CDs, instead of the latest downloads, and see how that fared. The installation CD, as I had semi-noticed previously, featured an interface in which the drivers were listed in order and then, once installed, were greyed out and could not be reinstalled from the CD (unless you removed them from the system, as I had just done). So on that basis, following the CD's order, I installed the drivers in this sequence, using their descriptions as they appeared on the installer interface: NVIDIA 650i System Driver Silicon Image 3531 SATA Drivers Realtek HD Audio Driver The Silicon Image thing was a potential problem. I already had two instances of it installed in Control Panel, and I didn't know how to remove either of them. But I proceeded with the installation, rebooting at each point when the installer wished to do so. This process seemed to work. I was very pleased to see that, in Device Manager, I now had only one yellow question, with Video Controller (VGA Compatible) under Other Devices -- and that was before I tried reinstalling the EVGA driver from CD. I had just realized, in these last few minutes, that when the Found New Hardware dialog bubble leads to an indication that the hardware might not work right, what was needed was probably not the latest and greatest driver, but just any driver at all that would at least cause the system to recognize the device in question, so you could be sure that your hardware was even functional. To which end, I now put on my headphones and tried the sound, and it worked. I was also mildly pleased to see that we had capped out at two Silicon Image SATA Controller entries in Control Panel. I installed the video drivers from the EVGA CD and, upon completing that, I had a completely yellow-free Device Manager. Now I faced the task of updating my drivers. Before I got too far with that, however, I found that I was once again dealing with a problem I thought I had solved, regarding weirdness in my video display.



I wrote up a relatively brief summary review of this board. It goes like this:

* * * * *

I bought an MSI (Micro-Star International) P6N SLI Platinum (MS-7350) motherboard in early July 2007. I proceeded to spend a large amount of time, over the next two months, dealing with crashes and hardware incompatibilities. I have detailed the process of working through the crashes in another post that deals with all sorts of issues; there is also another post, written later, that focused specifically on problems from this mobo. At this point, several months after the initial purchase, and after having swapped out the motherboard once already for a replacement from Newegg, I find that I still cannot use several significant pieces of hardware and software on the computer that houses this motherboard, whereas I was able to use them on my previous Gigabyte motherboard within the same computer and/or am able to use them on my underpowered little Dell Inspiron 2200 laptop. The items that I have not been able to use on this MSI motherboard include: Logitech webcam; Skype; VoSKY Internet Phone Wizard; Metal Gear Box external drive housing; and Canon CanoScan 8400F scanner.

The problem with Skype and the VoSKY, in particular, is that the system freezes up momentarily, in the middle of everything, and during those moments all voice communication is lost. Sometimes the call is dropped altogether. I thought this was a problem with Skype — I had not used it previously — but upon switching Skype and the VoSKY to my Inspiron, the problems went away immediately and have not returned.

The freezeups happen in other programs as well. In Acrobat, for example, which had previously been one of my most stable performers, the system suddenly stops in the middle of a scanning job, and requires anywhere from two to ten minutes to remember where it was and continue. The same thing happens in routine file operations. For example, selecting a couple hundred files from a list in Windows Explorer takes much longer than it did before. Some of that may be due to the loss of hyperthreading; the Core 2 Duo CPU that I am using on this computer apparently does not support multiple threads to the same extent as the Pentium 4 that I was using previously. But when you can work more effectively on an old Dell Inspiron than you can on a state-of-the-art system, you know something is wrong.

Although I am not sure, it seems possible that my mistake, in buying this motherboard, was to rely upon the views of reviewers who are oriented toward gaming. While gaming can tax the raw processing power of a system, it does not seem to call for the same versatility and ease of use that a person needs when s/he is running dozens of different programs and utilities with a deskful of peripheral devices (e.g., webcams, scanners, external drives). I was not aware that I was buying a board oriented toward gaming, and perhaps this one is not, but that is, anyway, my hypothesis to explain why such a highly rated board would do such a poor job for my everyday purposes. I do sincerely wish I had back, to use again, that month that I spent just trying to work through the hassles I experienced with this board, and I definitely do not recommend it for general-purpose use.